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1.0 Introduction  
 
Geospatial techniques offer an opportunity of analysis water resources and enhancing systems and 
livelihood resilience. Sustainable water resources and climate change adaptation are serious 
development challenges raising a daunting task in Uganda. yet, the development path of Uganda is 
premised on sustainable utilization of water resources. Geospatial technology has been rapidly 
developing and gigabytes of remotely sensed data is provided at high spatial resolutions. However, 
capacities in the utility of geospatial technology to address resilience issues are still lacking. This was 
noted in the HCD framework document for the water and sanitation sector of Uganda. This training, 
was thus envisaged to bridge that capacity gap.  

1.1 Objectives 
 

Ø To provide insight in recent and contemporary spatial technologies for watershed 
management and climate change adaptation   
 

Ø To equip participants with advanced GIS based skills for assessing resilience of water 
resources and dependent livelihoods. 

 

2.0 Content  

2.1 introduction to GIS 
Geographic Information System (GIS) is a 
computerized tool for capture, storage, retrieval, 
manipulation, analysis and display of spatial 
referenced data. With GIS application, you can 
collect spatial data, enter it into a GIS system, 
store for future use and carryout spatial analysis 
to create maps/graphs/tables that can aid spatial 
decision with the aim to improve agricultural 
development.  
 

2.2 History of GIS 
GIS is a relatively new field - it started in the 1970’s. Computerised GIS were only available to 
companies and universities that had expensive computer equipment. These days, anyone with a 
personal computer or laptop can use GIS software. Over time GIS Applications have also become 
easier to use - it used to require a lot of training to 
use a GIS Application, but now it is much easier to 
get started in GIS even for amateurs and casual 
users.  
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The developments in the field of computer technology have given new direction to handling and using 
spatial data for assessment, planning and monitoring. The concept of using the computers for making 
maps and analysing them was initiated with the SYMAP –Synagraphic mapping system, developed 
by Harvard School of computer graphics in the early 1970. Since then, there has been wide range of 
automated methods for handling maps using computers.  
 
The history of using computers for mapping and spatial analysis shows that there have been parallel 
developments in automated data capture, data analysis and presentation in several broadly related 
fields. All these efforts have been oriented towards the same sort of operation: namely to develop 
powerful tools for collecting, storing, retrieving at will, transforming, integrating and displaying 
spatial and non-spatial data from the real world for a particular set of purpose.  
 

The GIS can be used to solve broad range of problems as comparable to any isolated system for 
spatial and non-spatial data alone. For examples using a GIS: 

a) Users can interrogate geographical features displayed on computer map and retrieve 
associated attribute information for display 

b) Maps can be constructed by querying or analysing attribute data 
c) New sets of information can be generated by performing spatial operations 
d) Different items of attribute data can be associated with one another through a shared location 

codes 

2.3 Data types used in GIS 
Broadly, a GIS system use twofold categories of datasets: Spatial data and non-spatial data 

1) Spatial data. These are datasets (vector and raster) that have been prepared through field 
surveys or remote sensed data that is referenced on the earth’s surface. The composition of 
these datasets includes satellite images, coordinates among others that are interpreted to 
produce thematic maps which can aid agricultural planning towards to the sustainable use of 
limited resources  

2)  The non- spatial data are attributes as complimentary to the spatial data and describe what is 
at a point, along a line or in a polygon and as socio-economic characteristics from other 
sources. The attributes of a soil category could be the depth of soil, texture, erosion, drainage  
 

2.4 Spatial data structures 

2.4.1 Vector model 
It represents the geographical feature by a set of coordinates vectors as X, Y -coordinates define 

points, line and polygons. 

The types spatial data in GIS is generally described by X, Y coordinates and descriptive data are best 
organised in alphanumeric fields. The categories include: 

a) Points refer to a single place and usually considered as having no dimension or having 
dimension which is negligible when compared to the study for example the location of 
farmers and storage facilities etc 
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b) Line represents the linear feature and consists of series of X,Y coordinate pairs with discrete 
beginning and ending point for example rivers and road network 

c) Polygons are closed features defined by a set of linked lines enclosing an area. The polygons 
are character by area and perimeter for example the land use, the size of the farmer’s cropped 
fields  

2.4.2 Raster model 
It represents the image with help of square grids. The system stores an image by assigning a series of 

values to each cell identified by its Cartesian coordinates in space.  

Raster graphics are digital images created or captured (for example, by scanning in a photo) as a set of 
samples of a given space. A raster is a grid of x and y coordinates on a display space. A raster image 
file identifies which of these coordinates to illuminate in monochrome or color values. The raster file 
is sometimes referred to as a bitmap because it contains information that is directly mapped to the 
display grid. 

2.5 Coordinate Reference System 
A coordinate reference system (CRS) then defines, with the help of coordinates, how the two-
dimensional, projected map in your GIS is related to real places on the earth. The decision as to which 
map projection and coordinate reference system to use, depends on the regional extent of the area you 
want to work in, on the analysis you want to do and the availability of data. 

2.5.1 Map Projection in detail 
A map projection is one of many methods used to represent the 3-dimensional surface of the earth or 
other round body on a 2-dimensional plane in cartography (mapmaking). This process is typically, but 
not necessarily, a mathematical procedure (some methods are graphically based). 

2.5.2 Creation of a Map Projection 
The creation of a map projection involves three steps in which information is lost in each step: 

r selection of a model for the shape of the earth or round body (choosing between a sphere or 
ellipsoid) 

r transform geographic coordinates (longitude and latitude) to plane coordinates (eastings and 
northings). 

r reduce the scale (in manual cartography this step came second, in digital cartography it comes 
last) 

2.5.3 Metric properties of maps 
Maps assume that the viewer has an orthogonal view of the map (they are looking straight down on 
every point). This is also called a perpendicular view or normal view. The metric properties or a map 
are 

Ü area 
Ü shape 
Ü direction 
Ü distance 
Ü scale 
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2.5.4 Choosing a projection surface 
If a surface can be transformed onto another surface without stretching, tearing, or shrinking, then the 
surface is said to be an applicable surface. The sphere or ellipsoid are not applicable with a plane 
surface so any projection that attempts to project them on a flat sheet will have to distort the image 
(similar to the impossibility of making a flat sheet from an orange peel).  
 
A surface that can be unfolded or unrolled into a flat plane or sheet without stretching, tearing or 
shrinking is called a ‘developable surface’. The cylinder, cone and of course the plane are all 
developable surfaces since they can be unfolded into a flat sheet without distorting the projected 
image (although the original projection of the earth’s surface on the cylinder or cone would be 
distorted). 

2.5.5 The three families of map projections 
The process of creating map projections can be visualised by positioning a light source inside a 
transparent globe on which opaque earth features are placed. Then project the feature outlines onto a 
two-dimensional flat piece of paper. Different ways of projecting can be produced by surrounding the 
globe in a cylindrical fashion, as a cone, or even as a flat surface. Each of these methods produces 
what is called a map projection family. Therefore, there is a family of planar projections, a family of 
cylindrical projections, and another called conical projections 
 

 

Figure shows classification of map projection 

2.6 Spatial analysis 
Spatial analysis is the process of manipulating spatial information to extract new information and 
meaning from the original data. Usually spatial analysis is carried out with a Geographic Information 
System (GIS). A GIS usually provides manipulation and spatial analysis tools for calculating feature 
statistics and carrying out geoprocessing activities as data interpolation. For example, the tool will 
facilitate the computation of an area of land under cultivation, proximity of farmed land to the 
sensitive ecosystems and update layers etc 
 
Some of the tools used for spatial analysis include: 

 

 

Three families of map projection 

Cylindrical projection 
Conical projection 
Planar projection 
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a) Buffering. A buffer zone is any area that serves the purpose of keeping real world features 
distant from one another 

b) Clip: Refers to extraction of specific features from the input layer 
c) Merge: Refers to the combination of distant features 

 
 

2.7 Map production 
Map production is the process of arranging map 
elements on a sheet of paper in a way that, even without 
many words, the average person can understand what it 
is all about. Maps are usually produced for presentations 
and reports where the audience or reader is a politician, 
citizen or a learner with no professional background in 
GIS.  
 
Because of this, a map has to be effective in 
communicating spatial information. Common elements 
of a map are the title, map body, legend, north arrow, 
scale bar, acknowledgement, and map border. 
 

3.0 Introduction to GIS software 

3.1 Types of GIS software 
 

a) Geographic Information System (GIS) Software is designed to store, retrieve, manage, 
manipulate, display, and analyze all types of geographic and spatial data.  

b) GIS software enables you produce maps and other graphic displays of geographic information 
for analysis and presentation. 

c) We have two types of GIS software: Open source and commercial software 

3.2 Open source software 
The development of open source GIS software has—in terms of software history—a long 
tradition with the appearance of a first system in 1978. Numerous systems are available which cover 
all sectors of geospatial data handling. Eg QGIS, SAGA GIS, uDIG, JUMP GIS etc 
 
Most open source software is available for free and the users can benefit from the availability and 
transparency of the open source (program) code, which may be adapted for specific consumer needs 
and can again be shared within the community.  

3.3 Commercial software 
These are softwares that are purchased prior to usage in carrying out spatial analysis. Some of the 
notable software include: ArcGIS, ENVI, Erdas imagine, ESRI, Intergraph etc 
 

Map of Uganda created after over lay of 
GIS layers 
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3.4 Introduction to Esri technology 
Esri (Environmental Systems Research Institute, Inc) develops geographic information systems (GIS) 
that provides a variety of mapping functions that can be integrated into nearly every type of 
organization. Esri focuses on GIS because of the belief that "geography matters". Geography connects 
our many cultures and societies. GIS provides additional ways to understand cultures and societies 
which increases communication and collaboration opportunities. 

3.4.1 Key Functionality 
• Answer questions, test predictions, and examine relationships 
• Create, edit, and ensure the quality of geographic data 
• Create professional qualtiy maps 
• Manage data more efficiently 

3.4.2 History of Software Development  
a) Developer – ESRI - Environmental Systems Research Institute, Inc., started in 1969 as a 

privately held consulting firm that specialized in landuse analysis projects.  
a.1 Software Developers originated at Harvard graphics lab  

b) ArcInfo – early version of software  
b.1 Main-frame, unix-based software  
b.2 “arc” refers to line segments of map elements  
b.3 “info” refers to information in database system  
b.4 Command driven software package (analogous to “DOS”)  

c) ArcView (1990’s)– first release of a windows-based, GUI (graphical-user interface) based 
GIS system for desktop computers; still available but phasing out 

d) ArcGIS (2000’s) – next generation GIS software merging codes and routines from best of 
ArcInfo and placed in a GUI-Windows environment of ArcView, compatible with desktop 
computing 

3.4.3 Overview of ArcGIS Software  
Software collective referred to as “ArcGIS Desktop”  

i. Software Modules  
i.1 ArcMap – software used to display, analyze, and create GIS data  
i.2 ArcView level install – basic level application  
i.3 ArcEditor – step up, includes data editing capabilities  
i.4 ArcInfo – highest level install, with advanced editing and analysis features  
i.5 ArcCatalog- tool for viewing and managing spatial data files (analogous to Windows 

Explorer) 
i.6 ArcToolbox – set of tools and functions used to convert data formats, manage map projections, 

perform analysis, modify data.  
ii. Extensions  

ii.1 The Extensions dialog allows you to load and unload software capabilities, allowing you to 
enhance your working environment with additional objects, scripts and customization.  

ii.2 You can use extensions provided by ESRI and you can also create your own. 
iii. Data Files in ArcGIS  

iii.1 Shapefiles – developed for ArcView 
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ArcView shapefiles are a simple, non-topological format for storing the geometric location and 
attribute information of geographic features. A shapefile is one of the spatial data formats that you 

can work with in ArcView. The shapefile format defines the geometry and attributes of 
geographically-referenced features in as many as five files with specific file extensions that should be 

stored in the same project workspace 

3.4.4 The capabilities of the ArcGIS licences 

 

3.4.5 ArcGIS software system 
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3.5 ARCGIS Desktop 

  
 

3.6 Mapping application  
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3.7 Arc Catalog  
 
 

3.8 Geo-processing shapefiles 
This section introduces you on how to process a shapefile ready for analysis. This is a common task if 
you want to extract information from the spatial layer. The aim of processing is to make the data 
usable. Geoprocessing is essentially a GIS operation used to manipulate the spatial aspects of GIS 
data. In the broad sense the tools include: overlay, clipping, update, feature selection, union, and 
dissolve among others 

3.8.1 Geo-processing tools 
1. Convex Hulls - creates the smallest possible convex polygon enclosing a group of objects 

Vector > Geoprocessing Tools > convex hull(s). 

 

2. Buffers - creates an equal zone around specific features at a specified distance 
Vector > Geoprocessing Tools > Intersect. 
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3. Intersect - creates new layer based on the area of overlap of two layers 
Vector > Geoprocessing Tools > Intersect 

 

4. Union - melds two layers together into one while preserving features and attributes of both 
Vector > Geoprocessing Tools > Union 

 

5. Symmetrical Difference - creates new layer based on areas of two layers that do not overlap 
Vector > Geoprocessing Tools > Symmetrical Difference 

 

6. Clip - cuts a layer based on the boundaries of another layer 
 Vector > Geoprocessing Tools > Clip 

 

7. Difference - subtracts areas of one layer based on the overlap of another layer 
Vector > Geoprocessing Tools > Difference 

 

8. Dissolve - merges features within a single layer based on common attributes in the attribute 
table 

Vector > Geoprocessing Tools > Dissolve 

 

9. Eliminate Sliver Polygons - merges left-over or misformed geometry with neighboring feature 
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4.0 GIS data sources 

4.1 Introduction  
The processes of data collection are also variously referred to as data capture, data automation, data 
conversion, data transfer, data translation, and digitizing. 
 
Two main types of data capture are 
  

r Primary data sources are those collected in digital format specifically for use in a GIS project.  
r Secondary sources are digital and analog datasets that were originally captured for another 

purpose and need to be converted into a suitable digital format for use in a GIS project. 

4.2 GIS data collection workflow 
a) Planning includes establishing user requirements, garnering resources, and developing a 

project plan.  
b) Preparation involves obtaining data, redrafting poor-quality map sources, editing scanned 

map images, removing noise, setting up appropriate GIS hardware and software systems to 
accept data.  

c) Digitizing and transfer are the stages where the majority of the effort will be expended 
d) Editing and improvement covers many techniques designed to validate data, as well as correct 

errors and improve quality. 
e) Evaluation is the process of identifying project successes and failures. 

 

4.3 GIS data collection methods 
 Raster Vector 

Primary Digital remote sensing images GPS measurements 

 Digital aerial photographs Survey measurements 

Secondary Scanned maps Topographic surveys 

 DEMs from maps Toponymy data sets from atlases 
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4.4 Source of GIS Data 

4.4.1 Introduction  
Most projects begin with a search for baseline data.  Some of this data exist either through online or 
offline domains. The online datasets are normally open sources and can be easily assessed, whereas 
the offline datasets are available through the mandated organizations such as NGOs, international 
development partners and government bodies. Indicated here below is a list spatial datasets and 
mandated institutions/organisations 
 

No General purpose Type  Scope 
 Online   
1 http://www.ngdc.noaa.gov/mgg/shorelines/gs

hhs.html 
Land and ocean boundaries World  

2 http://asterweb.jpl.nasa.gov/gdem.asp Elevation  World 
3 http://www.worldclim.org/ Weather and climate World 
4 http://hydrosheds.cr.usgs.gov/ Hydrology  World 
5 http://nelson.wisc.edu/sage/data-and-

models/global-land-use/grid.php 
Global land cover World 

 Regional Center for Mapping of Resources 
for Development 

Spatial data East and southern 
Africa 

 Agriculture (online)   
 http://harvestchoice.org/ Agricultural related – yields, 

production, travel time to 
markets,  

Africa 
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 http://gaez.fao.org/Main.html# 
 

Agricultural related – 
consumption, suitability, 
yields, production e.t.c 

World 

 http://ratin.net/site/map Storage facilities EAC 
 http://www.rtb.cgiar.org/RTBMaps/ Suitability, yields and 

production 
Africa 

 http://www.infrastructureafrica.org/document
s/tools/list/arcgis-shape-files 

Roads, boundaries, water 
bodies and power plants 

Africa 

 

5.0 Creating maps using digital geographical information  

5.1 Introduction 
This module exposes the participants on how to create maps using existing GIS datasets (raster and 
vector) collected from different sources to aid the spatial decision-making process. 

5.2 Datasets  
Making maps in ArcMap is very easy: Browse geospatial data in ArcMap and choose an appropriate 
presentation.   
 
Steps Challenges  
Load geospatial data into Arcmap Data formats and folder connections 
Identify the features and attributes to 
present 

Layer order, feature selection and projections 

Define how to show the data Transparency (raster and vector) data classification and 
layer file 

Add map components Geospatial data referencs 
Export maps Resolution and file formats 
 
 
The working folder is named “GIS folder” and it contains the following spatial datasets 
 
Datasets  Units  

Districts Meters  

Lakes  Meters 

Land use/cover meters 

Rivers Meters 

Protected areas Meters  

Elevation (30m) Meters  

Roads Meters 

5.3 Task 
In this case, we want to create a land use map for Mbale District 



Pilot course content – Human Capacity Development Framework Uganda 
 
 

 
Page 19 of 76 

 
 

5.4 Procedures  

5.4.1 Load data 
a) To launch Arcmap please click: Start -> All Programs -> ArcGIS -> ArcMap 10. By default, a 

start-up splash window will appear once ArcMap has loaded 
 
b) Click OK to proceed. You can ignore all other options. 
 

 
 

There are two ways to add data: Click the Add Data   button (Figure 2), which opens a 
window similar to Figure. 
 

 
 
 
c) To browse to the file you want to play with, you can link to the folder containing all these files by 

clicking the Connect to Folder  button, then browse to add the folder that contains your files 
and click OK.  
 

d) After that, you can locate the files listed below and add them in at one time by holding the Ctrl or 
Shift button when you are clicking mouse button to make selections. Please click the Add button 
just like any other file explorer dialogs in Windows to close the dialog.   
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When data is loaded, all files will be listed in the left pane (table of contents). The geographic 
features (contents) are displayed in the right pane. And most controls can be found on the top pane (or 
by right-clicking on the object you are working at and checking the pop-up window). 

5.4.2 Browse Geographic Features  
a) In ArcMap 10.2, ESRI starts to put most controls to browse data into one tool bar. If you 

cannot find this toolbar, please go to Customize -> Toolbars and check the Tools on.    
 

b) Select Mbale district from the loaded Ug_district layer 
 

 
 

c) Click on the select features by rectangle and choose Mbale district 
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d) Extract Mbale from the broader Ugandan shapefile 

 
 

e) Extracted Mbale District 
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5.4.3 Geoprocessing 
 

a) In this module we are going to extract features such as roads, rivers, protected areas etc that 
lie within Mbale District 

 
 
 

 
 

b) Click on Geoprocessing from the Menu – Clip (Extracts input features that overlay the clip 
features) 
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c) In clipping  

 
 
 

d) The output is as follows   
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e) Therefore repeat the same procedure for clipping (as in b-above) for the rest of the datasets 

(e.g. rivers, sub counties, protected areas etc) 

Mbale district with clipped 
a. rivers 
b. sub counties 
c. protected areas 

 
 

f) The next step is to  processes the clipped datasets from the table of contents 

5.4.4 Defining the General and Symbology Properties for a Layer 
 
In this section of the tutorial, you will learn how to organize your data layers' properties to start 
bringing some coherence to the map.  
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If you haven't turned off the labels already, turn them off now by right-clicking on the roads data 
layer for example and unchecking Label Features. This will speed things up while you work. 

5.4.5 Assigning proper layer names 
 

S First, you need to give the data layers better names than what they have (e.g., roadclip should 
say "Roads")   

 
S Right click on the road layer and choose Properties (alternatively, you can double click On 

the data layer name). 
 

S When you see the Properties dialog box, click on the General tab. In the Layer Name 
S box, type in Streets instead of road. Press OK when finished. 

 
S Give all the other layers more coherent names as best as you can (e.g. “Sub county boundary” 

instead of subcountyclip, “Rivers” instead of Rivers_clips, “Protected areas” 
S instead of protected areas_clip ). In the future, we will deduct points on assignments for 
S having non-standard English "data-speak" names like "streetscl" appearing in your map 

 

 
 

5.4.6 Assigning proper colors 
 
Your map would be a lot better if the rivers were colored blue, the parks green, etc.  
 
1) Right-click on the rivers layer to bring up the Properties dialog box again.  
2) Click on the Symbology tab  
3) To change the color of the layer, click on the colored box under Symbol - this should  

bring up the Symbol Selector box.  

Change layer names from here 
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4) Click on the small colored box next to Fill Color, to see colors to choose from – choose a blue 
color for water 

 

 
5) Press OK when you are finished, and OK again to return to your map. 

 
Note 
6) The sub county layer still appears fairly Light red (rose) – that’s because the symbology  settings 

have applied a black outline around the gray fill. You (and your map’s viewers) do not need to see 
these outlines.  

7) Turn the outlines off by going back to the layer's properties and the Symbology tab. Once again 
click on the colored box under Symbol.  

8) Then click on the small box just right of Outline Color, and choose No Color. Press OK and OK 
again to get back to your map. This is how you turn outlines off (you can also change their color 
or thickness). 

 

1 

2 

3 
Note:  
 
Assign appropriate colors to the 
remaining data layers 
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5.4.7 Labelling  
The labels are an important feature of a map. By marking some property up on the map, for stance, 
the name of the marked location, labels can make your map more useful, informative, and visually 
appealing.   
 

Ü To add labels to your map, please right-click on the layer that you want to add marks on 
(sub counties) and select Properties. Then follow the steps below 

o Select the Labels tab and check on (off by default) “Label features in this layer”.  

	
Turn on the neighborhoods layer and go to its 
symbology properties. Use the “Hollow”  
scheme (no fill color, with an outline), and make 
the outline width thicker (e.g., 2) as 
shown below: 
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o Choose the attribute you want to display (SNAME) on the map in the dropbox of 
Label Field  

o Change Font (10 pt size), so that it is clearly shown on the map. 
o You can click on the Apply button to see the effect until it is satisfactory. Then 

click OK to save your setting and exit. 

 
 

Labelled sub counties 

 
o To ensure a clear label, the option of mask can be used Symbol, which locates to 

the right of Font options as a Symbol button.  
o Please click it and then click the Edit Symbol button, since label is a kind of 

symbol (text symbol) too.   
o Navigate to the Mask tab shown in the figure below. Change the option of Style 

to Halo   
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Before we create our final map – make sure that layers are checked in the 
table of content and are as follows 
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5.4.8 Map Components 
Then you select Layout View to start adding map components, all components are gathered in the 
menu of Insert.  

 
The key ones are:  

Ð The title of the map (Purpose/Content); 
Ð The scale of the map (Measurement); 
Ð The North Arrow (Orientation); 
Ð The Legend (how to interpret the map); 
Ð (Optional) The reference (where you obtain the data) 

 

 
 
Ð Map titles are just a specific kind of text box with some pre-defined fonts. Hence, the usage of 

title and text are identical and intuitive: type in the content and customize the text properties.  
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Ð To manipulate the title – double click – change system – change font to Arial – bold and click 

OK 
 
 
 
 

Ð Add scale bar or scale text is also intuitive. The only thing that should be noted as the display 
unit, suchas meters, degrees, miles, etc. You can customize it by clicking the Properties button in 
the Scale Bar (or Text) Selector, which is the pop-up window when you choose Insert -> Scale 
Bar (or Scale Text).  In the Scale and Units tab, you can choose an appropriate unit in the 
Division Units dropbox 
 

 
 

Ð In addition, you can change the font style under the Format tab as well. 
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Ð Add North Arrow is the easiest task, which is very similar to add a scale bar. Just choose a pre-
defined north arrow from the library shown in the left pane is ok. If your North Arrow is difficult 
to be distinguished from the background, you can add some background color, which has similar 
effect of “mask” for labels. This option normally locates in the Frame tab 

 
 

Ð Adding Legend is somewhat complex and deserves some explanation. When Insert -> Legend is 
selected, ArcMap will use a wizard guiding you through various options of making a legend.   

Ð Note 
o At the first step, you will be asked about which layers need legend and the order of 

adding legend. The left pane Map Layers displays all layers (geospatial data) 
available for the map.  

o The right pane Legend Items shows the layers that will be added to the legend in 
order.   

 
a) Add/Remove Layers: You can decide the layers to be added to the legend by clicking  to add 

or  to remove.   
b) Change the Display Orders: The legend items will be added strictly in the order shown in the 

Legend Items pane. You can change the order by clicking a layer first (displayed in the blue 
bar) and move it up or move it down . 
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Ð Adding more information onto the map (e.g. date, projection parameters) 

 
 
 
 

 
Ð Insert grids into your map 
Click on View – Data Frame properties – grids – new grid – measured grid – click next until OK 
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5.4.9 Export Maps 
1) Format page settings (Decide if your work is to be printed A2, A4 etc paper size) 
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2) When you are satisfied with everything in the map and are ready to deliver, you can export 
your map by the menu of File -> Export Map, which will pop-up a dialog  
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Highlights 
 
1) You can specify the directory and file name of the map in this dialog. But, most importantly, you 

need to choose an appropriate file format by click on the Save as type dropbox. The most 
frequent-used formats are JPEG and PDF. JPEG is a popular graphic file format, which is easy to 
be inserted into word as a graph, while PDF is best used for sharing. The printed copy of PDF will 
be identical regardless of your computer (and printer) environment.   

 
2) Please note that if the purpose of your map is to be shown on screen, 96 dpi resolution is good 

enough. It is especially true when you want to publish your map online, given that lower 
resolution maps are much smaller, and therefore, easier to transfer via Internet. If you need hard 
copies of your map, please make sure that the resolution is set to 300 dpi or 600 dpi. Otherwise 
the output map might be obscure.   

 
3) Other than export map to other file formats, you can directly print out hardcopies of your map by 

File -> Print. You can preview the result via File -> Print Preview to ensure satisfactory result. 
And, of course, you can customize page and printer setup via File -> Page and Print Setup, such 
as page orientation, page size, printer configuration (color or grey), and so on. All these 
operations are intuitive and very similar to other applications, such as Microsoft Word.   
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Final map  
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6.0 Mapping of environmental features using GPS units 

6.1 Introduction to Global Positioning Systems  
The Global Positioning System (GPS) is a satellite-based navigation system made up of a network of 
24 satellites placed into orbit by the U.S. Department of Defense. GPS was originally intended for 
military applications, but in the 1980s, the government made the system available for civilian use. 
GPS works in any weather conditions, anywhere in the world, 24 hours a day.  

6.2 How it works 
GPS satellites circle the earth twice a day in a very precise orbit and transmit signal information to 
earth. GPS receivers take this information and use trilateration to calculate the user's exact location. 
Essentially, the GPS receiver compares the time a signal was transmitted by a satellite with the time it 
was received. The time difference tells the GPS receiver how far away the satellite is. Now, with 
distance measurements from a few more satellites, the receiver can determine the user's position and 
display it on the unit's electronic map. 

 

 

A GPS receiver must be locked on to the signal of at least 3 satellites to calculate a 2-D position 
(latitude and longitude) and track movement. With four or more satellites in view, the receiver can 
determine the user's 3-D position (latitude, longitude and altitude). Once the user's position has been 
determined, the GPS unit can calculate other information, such as speed, bearing, track, trip distance, 
distance to destination, sunrise and sunset time and more. 

6.3 How accurate is GPS? 
Today's GPS receivers are extremely accurate, thanks to their parallel multi-channel design. Our 12 
parallel channel receivers are quick to lock onto satellites when first turned on, and they maintain 
strong locks, even in dense foliage or urban settings with tall buildings. Certain atmospheric factors 
and other sources of error can affect the accuracy of GPS receivers. Garmin GPS receivers are 
accurate to within 15 meters, on average. 
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Newer Garmin GPS receivers with WAAS (Wide Area Augmentation System) capability can improve 
accuracy to less than 3 meters on average. No additional equipment or fees are required to take 
advantage of WAAS. Users can also get better accuracy with Differential GPS (DGPS), which 
corrects GPS signals to within an average of 3 to 5 meters. The U.S. Coast Guard operates the most 
common DGPS correction service. This system consists of a network of towers that receive GPS 
signals and transmit a corrected signal by beacon transmitters. In order to get the corrected signal, 
users must have a differential beacon receiver and beacon antenna in addition to their GPS. 
 

 

6.4 The GPS satellite system 
The 24 satellites that make up the GPS space segment are orbiting the earth about 12,000 miles above 
us. They are constantly moving, making two complete orbits in less than 24 hours. These satellites are 
travelling at speeds of roughly 7,000 miles an hour. 
 
GPS satellites are powered by solar energy. They have backup batteries onboard to keep them running 
in the event of a solar eclipse, when there's no solar power. Small rocket boosters on each satellite 
keep them flying in the correct path. 
 
Here are some other interesting facts about the GPS satellites (also called NAVSTAR, the official 
U.S. Department of Defense name for GPS): 
a) The first GPS satellite was launched in 1978. 
b) A full constellation of 24 satellites was achieved in 1994. 
c) Each satellite is built to last about 10 years. Replacements are constantly being built and launched 

into orbit. 
d) A GPS satellite weighs approximately 2,000 pounds and is about 17 feet across with the solar 

panels extended. 
e) Transmitter power is only 50 Watts or less. 

6.5 What's the signal? 
GPS satellites transmit two low power radio signals, designated L1 and L2. Civilian GPS uses the L1 
frequency of 1575.42 MHz in the UHF band. The signals travel by line of sight, meaning they will 
pass through clouds, glass and plastic but will not go through most solid objects such as buildings and 
mountains. 
 
A GPS signal contains 3 different bits of information - a pseudorandom code, ephemeris data and 
almanac data. The pseudorandom code is simply an I.D. code that identifies which satellite is 
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transmitting information. You can view this number on your Garmin GPS unit's satellite page, as it 
identifies which satellites it's receiving. 
Ephemeris data, which is constantly transmitted by each satellite, contains important information 
about the status of the satellite (healthy or unhealthy), current date and time. This part of the signal is 
essential for determining a position. 
 
The almanac data tells the GPS receiver where each GPS satellite should be at any time throughout 
the day. Each satellite transmits almanac data showing the orbital information for that satellite and for 
every other satellite in the system. 
 

 

6.6 Some of the GPS applications in the agricultural sector 
The application of GPS in agriculture is not limited to; location of beneficiaries, farm size 
determination, mapping infrastructure, monitoring weeds, pests and disease spread, and crop damage 
due to drought and hailstorms.  
 
A field map can be created using GPS to record the coordinates of field borders, fence lines, and point 
locations such as wells, stores, buildings, and landscape features. The resulting field map might be the 
first layer a producer would develop for an on-farm GIS (Geographic Information System). 
Additional layers showing crop damage from hail or drought, and riparian areas or wetlands could be 
mapped using GPS. 

6.7 Sources of GPS signal errors 
Factors that can degrade the GPS signal and thus affect accuracy include the following: 

è Ionosphere and troposphere delays - The satellite signal slows as it passes through the 
atmosphere. The GPS system uses a built-in model that calculates an average amount of delay 
to partially correct for this type of error. 

è Signal multipath - This occurs when the GPS signal is reflected off objects such as tall 
buildings or large rock surfaces before it reaches the receiver. This increases the travel time of 
the signal, thereby causing errors. 

è Receiver clock errors - A receiver's built-in clock is not as accurate as the atomic clocks on-
board the GPS satellites. Therefore, it may have very slight timing errors. 

è Orbital errors - Also known as ephemeris errors, these are inaccuracies of the satellite's 
reported location. 
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è Number of satellites visible - The more satellites a GPS receiver can "see," the better the 
accuracy. Buildings, terrain, electronic interference, or sometimes even dense foliage can 
block signal reception, causing position errors or possibly no position reading at all. GPS 
units typically will not work indoors, underwater or underground. 

è Satellite geometry/shading - This refers to the relative position of the satellites at any given 
time. Ideal satellite geometry exists when the satellites are located at wide angles relative to 
each other. Poor geometry results when the satellites are located in a line or in a tight 
grouping. 

è Intentional degradation of the satellite signal - Selective Availability (SA) is an intentional 
degradation of the signal once imposed by the U.S. Department of Defense. SA was intended 
to prevent military adversaries from using the highly accurate GPS signals. The government 
turned off SA in May 2000, which significantly improved the accuracy of civilian GPS 
receivers. 

6.8 Setting up GPS 
GPS receivers are simple electronic devices and as such the way their set up will affect what data is 
collected. Before going into the field all staff must know how to use the GPS receiver, what to check 
for before collecting data, and simple maintenance of the devices. Every GPS receiver will be slightly 
different, so it is not possible to give exact details in this document. The manual that came with the 
GPS receiver should be used to find the exact methods to carry out the tasks listed below.  
 
GPS receivers work by receiving signals from satellites that orbit the Earth. When you use the 
receiver for the first time, it has to find the satellites and update all its information on satellite 
locations. Most GPS receivers call this “Searching the sky”. This process can take up to 30 minutes, 
during which the GPS should be left somewhere with a clear view of the sky. Once the process is 
complete the position will be shown on the screen. This process must be repeated if the receiver is not 
used for 4 months or if it is moved large distances, i.e. between countries or within very large 
countries. If you move less than 200km from the previous location then the update will not be 
required. 

6.9 Recording GPS coordinates 
Waypoint coordinates may be recorded in different ways: Write on paper record in the device and 
download later, Type into a database, Enter into a storage device. The simplest is to have two columns 
on a paper form to enter the coordinates. The X coordinate and Y coordinate can simply be written 
down into the correct columns. It is important to ensure they are written down correctly. Having 
written down the coordinates it should be double checked to reduce errors.  
 
This method works best if other information is being collected at the same time, e.g. information 
about a case or structure. If only the coordinates are being collected then it can be stored in the GPS 
receiver as a waypoint. Most GPS receivers will store up to 250 waypoints at a time. Having got the 
location the waypoint is created or marked. This stores the coordinates to be downloaded directly into 
a computer at a later date. If storing coordinates this way, you still have to keep a written record of 
what each waypoint represents. Care needs to be taken to ensure these waypoints are downloaded. 
Check frequently to avoid the memory filling up. 
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By storing the location as waypoints in the GPS device, Google Earth can map the waypoints directly 
(in Google Earth select Tools / GPS select Garmin – waypoint and click Import). 

6.10 Maintenance  
a) GPs receivers should be regularly checked and maintained. There are two main parts to this:  
b) Check batteries. GPS receivers batteries usually only last for between 14 – 16 hours. The 

simplest way to do this is to turn the receiver on and there is no “Low battery” warning. It is 
vital that especially when going to remote locations that there are spare batteries.  

c) Clean up memory. Receivers store information and this can be confusing. GPS receivers 
should be regularly cleaned up with all waypoints and tracks removed so that all the memory 
is available. 

6.11 Defining protocols for field use 
The information that should be defined as part of the field protocols includes:  

a) Coordinate system and Map Datum  
The default coordinate system and map datum should be latitude and longitude, and WGS 84. 

Only on rare occasions should anything else be used 

b) Acceptable accuracy for waypoints  
Standard GPS receivers are only guaranteed accurate to 20m however in locations with only 1 

storey buildings the accuracy is usually better than 10m. The accuracy required should be 
defined and waypoints only collected when the accuracy is below that threshold. 

c) Position to stand to find location  
a. So a protocol defining the default locations should be tested before starting field 

work. For village centroids or area centroids, somewhere on the main road / path 
through the village may be a suitable location.  

b. For a house it may be suitable to stand 1 – 2m in front of the main entrance to the 
house 

d) Checking / maintenance routine 
There should be a protocol for verifying the coordinates collected and for maintenance of the GPS 

receivers 

6.12 Field Area calculation 
a) Switch on your GPS units and wait shortly for an improved accuracy 
b) Go to the main menu  and select Area calculation  

You can calculate Area and Display in: 

a) Acres 
b) Square Miles 
c) Square Feet 
d) Hectares 
e) Square Kilometers 
f) Square Meters 
 



Pilot course content – Human Capacity Development Framework Uganda 
 
 

 
Page 45 of 76 

 
 

c) Press START and you move around the field until you reach the original departure point and 
then stop the calculator 

d) Record the field computations in your Notebook  
e) Enter the recorded computations into an excel sheet as an attribute “area” 

6.13 Procedures of adding the collected coordinates into Arcmap 

6.13.1 How capture coordinates 
 

a. Open Ms Excel and enter the captured coordinates from the field for spatial display and 
analysis 

b. Save the excel file in your working folder  and close excel 
 

 
 

c. Launch ArcMap and load the excel file to add the coordinates 
d. Navigate to your Excel spreadsheet and double-click the sheet 

 
 

e. Select “sheet 1” 
f. The Excel table will be added to ArcGIS and appear in the table of contents. 
g. Right click the added excel table from the table of contents – Display XY data 
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h. Define X and Y fields and then click OK 
i. An event later will be created with your points. 
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j. Label the add XY points and also add the Mbale district boundary data using the previous 

exercise of creating a map using existing layers 
 

 
k. Lastly, save the displayed points as a feature class, this is because: 

a. This XY data will not be saved in memory once ArcGIS is closed. To save the points 
data, you need to create a feature class or shapefile. 

b. So right-click the event layer and export data (data > export data). Click “use the 
same coordinate system as the data layer”. 

c. Save the file and you have just created a spatial file from an Excel spreadsheet. 
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l. Save the shapefile in your working folder as (Mbale_GPS_coordinates) 
 

6.14 Symbolizing layers 

6.14.1 Manipulation of layer properties 
 
1. Double click -> shapefile from table of contents or  Right click -> the shapefile ->properties-

>symbology 
 

 
 

6.14.2 Layer Catergories 
2. Click symbology -> categories ->unique values  
3. Value field -> DNAME2011 -> click on add all values -> OK 
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6.15 Lab Exercise: Data Capture, Analysis and Dissemination with a focus 
on GPS and Coordinate Systems 

 
PART A: Aerial Photography 

 
Section 1. Understanding aerial imagery in ArcMap 
 
We will be discovering the properties of an aerial photograph. The aerial photo we will use comes 
from the Virginia Base Map Photography (VBMP) program. 

1. Open ArcMap to a new map, and add the aerial photograph D0_S03_9621_10.sid to your 
map. 

2. First, learn about the aerial photograph.  From the layer properties, record the following: 

1. Columns and Rows:      

2. Number of bands:      

3. Cellsize (X, Y):      

4. Pixel depth:       

Note about images: Images can require substantial disk space.  The space required to store an 
image is a function of the number of rows and columns, the number of bands, and the pixel depth, 
or number of bits of data stored for each image pixel. 

3. Estimate the number of megabytes needed to store this image: multiply the number of rows 
times the number of columns times the number of bands times the number of bytes (not bits!) 
of pixel depth. 

1. Bytes to store image:     

2. Megabytes (divide by 1,048,576 bytes in a megabyte; record to two decimals): 
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3. Check this answer against the “uncompressed size” recorded in the layer properties.  
Also, you can get an idea of the importance of image compression by looking at the 
space that this file uses in your folder (in My Computer, look at the files in the folder, 
using the “details” view to see file sizes.  Remember that 1 MB is 1,024 KB). 

4. Now record information about the coordinate system used for this image: 

1. Linear unit:       

2. Spatial reference (coord. Sys.):      

3. Datum:         

Note: If you zoom into an individual pixel and use the measure tool to measure it, does it confirm 
the pixel cellsize recorded above?  Pay attention to units. 
 

Section 2. Examining the impact of coordinate datums 
 
Now we will see what happens when map data is displayed in different coordinate systems in 
ArcMap. 

 
5. Find a location in your image that you can zoom to repeatedly and find the same point to 

within one pixel (e.g., a sidewalk corner, a painted patch on a road, a lamppost, etc.).  Now 
zoom in to where you can clearly see the individual pixel (i.e., a scale of around 1:20 to 1:40).  
Move your cursor to either a center or corner of the pixel and record the coordinate displayed 
in the lower right of the ArcMap window.  These coordinates should be in the same 
coordinate system as the image (recorded as the spatial reference above). 

1. X-Coordinate:      

2. Y-Coordinate:      

6. Now, change the coordinate system of the Data Frame to be UTM NAD 27 (predefined, 
projected coordinate systems, UTM, NAD 27, Zone 17N).  Record the coordinates: 

1. X-Coordinate:      

2. Y-Coordinate:         

7. Now, change the coordinate system of the Data Frame to be UTM NAD 83 (predefined, 
projected coordinate systems, UTM, NAD 83, Zone 17N).  Record the coordinates: 

1. X-Coordinate:      

2. Y-Coordinate:         

8. Calculate the difference between these: 

1. Difference in X (‘easting’; 7a - 6a):     

2. Difference in Y (‘northing’; 7b - 6b):     

3. Distance (square root of ([8a * 8a] + [8b * 8b])):    

4. This distance (in meters) represents the shift between the datum NAD 27 and the 
datum NAD 83.   

   
PART B: COLLECTING, ANALYISING AND MAPPING FIELD DATA 

 
 
Section 3. Collecting and storing GPS Data. 
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In this section, you will work with other trainees to collect coordinates at corners of an assigned area 
on campus. 

9. You will be issued one GPS unit per two- or three-person team, along with instructions for 
using the unit and an assigned area in which to collect data. 

10. Be sure you understand how to identify and change the coordinate system with which your 
GPS unit will display coordinates.  You should set your unit to display coordinates in UTM, 
WGS84, meters. 

1. Visit the area and collect data per your instructions.   Your primary task is to collect 
positions at corners of the area you are assigned. 

11. At each location (waypoint, landmark), store the point on your GPS unit, but also fill in the 
appropriate information on the attached data sheet. 

12. Next, open Microsoft Excel and enter your data into a spreadsheet. 

1. Make sure you use the column headings specified on your worksheet (when you save 
this in a different format, column headings with spaces or special characters create 
problems). 

2. You do not need to enter the comment column but you may if you wish. 

13. When you are done, save your worksheet file as an Excel workbook (use the last name of one 
of the team members).  

 
Section 4. Importing GPS data into ArcMap. 
 
Next, we will load the data file containing GPS coordinates into a format for use by ArcMap.  We 
must "define" a coordinate system for our data files so that ArcMap can display our maps 
appropriately. 
 
14. Open ArMap and add the Uganda Administrative Boundaries layer provided.  Follow the 

ArcMap Help instructions for “Adding XY Data” to add the points from your Excel file into 
ArcMap.  You will have to instruct ArcMap what coordinate system was used for your GPS 
points. 

15. An "Events" layer will be added to your map, consisting of points.  This is not a shapefile, but 
you will convert it to one: 
1. Right-click on the layer name and select "Data" then "Export Data…" 
2. In the Export Data dialog, pay attention to the choices offered and make sure you 

understand them.  Is the coordinate system for the data frame different than the 
coordinate system for your Events layer?   

3. Add the exported shapefile to a map. 
4. To avoid later confusion, remove the "Events" layer. 

16. Examine your map to see how well the GPS points overlay in the appropriate locations on the 
Uganda Administrative Boundaries layer. 

 

 

 
Section 5. Calculating Area manually. 
 
Next, we will calculate the area bounded by the GPS points you collected.  We will do this in two 
ways: manually and within ArcMap.  You can perform the manual approach either using an Excel 
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spreadsheet or a hand calculator.  The algorithm will be described here, and it will be up to you to 
implement this with calculator or spreadsheet. 
 
 
Area Calculation Algorithm: 
 
Consider a series of n coordinate pairs, (X1, Y1) to (Xn, Yn); these pairs are in clockwise sequence 
around a polygon: 
 
The area of the polygon is 
calculated as the absolute value 
of: 
 
 
 
 
 
 
 
 
 
Where Xn+1 = X1  
and Yn+1 = Y1 
 
So for the example polygon shown, n=5 and the area is calculated as: 
 
A = [(X1Y2 - X2Y1) + (X2Y3 - X3Y2) + (X3Y4 - X4Y3) + (X4Y5 - X5Y4) + (X5Y1 - X1Y5)] / 2 
 
Area (A) will be expressed in square distance units of the coordinates.  If coordinates are in meters, 
Area will be in square meters. 
 

17. What is your polygon area (square meters)?     

18. What is the polygon area in acres?      

 
Section 6. Creating a polygon from GPS points. 
 
We have a point shapefile of the GPS points you collected.  But points don't have area; polygons do!  
We must create a polygon shapefile from these points.  There are several ways to do this, but you 
might as well learn how to create polygons through "on-screen digitizing", or "heads-up digitizing", 
where the map you are digitizing is displayed on the screen in front of you. 
 
19. First, we must create an empty polygon shapefile that we will subsequently edit to add a 

polygon: 
1. Open ArcCatalog. 
2. Select the folder where you want this shapefile to be created. 
3. From the ArcCatalog "File" menu, select "New" and then "Shapefile…" 
4. Give your new shapefile a name and specify that it is to be a polygon feature type. 
5. Click the "Edit" button in the Spatial Reference area to Select the UTM, WGS84, 

meters coordinate system as you did before when adding XY data. 
6. Click OK.  ArcCatalog will create a new, empty file ready for your polygon. 

X1, 

X2, 

X3, X4, 

X5, 

[(XiYi+1)-(Xi+1Yi)] 

i= 1 

n 

2 

Σ 
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20. Go back to ArcMap and add this shapefile to your map.  It will be empty, but the symbol that 
displays in the table of contents should indicate that this shapefile will contain polygons, not 
lines or points.  If it doesn’t, then you did not do step 19 correctly! 

21. In ArcMap, zoom in to your GPS points shapefile; you may leave the aerial photo displayed 
in the background. 

22. We need to add the Editor toolbar to your ArcMap interface: 
1. From the "Tools" menu, select "Customize…"  
2. Check the box for the "Editor" toolbar. 
3. Click "Close". 
4. You now have the Editor toolbar in your interface.  It contains the Editor pull-down 

menu, some icons, and places to specify your editing "target" and "tasks". 
23. From the Editor pull-down menu, select “Start Editing” to edit the shapefile you added above. 
24. Set the Editor "Target" to be this new, empty polygon shapefile. 
25. From the Editor pull-down menu, select "Snapping". ("Snapping" allows you to "snap" your 

digitized points exactly to points in another layer.  In this case, we will want to snap exactly 
to the GPS coordinates in your point file). 
1. Check the box to indicate that you want to snap to "Vertex" in the point layer. 
2. Close the Snapping Environment window. 

26. Now, in the Task menu on the Editor toolbar, set the Task to be "Create New Feature". 
27. We are now ready to digitize the polygon: 

1. Click on the pencil icon to the left of the Task menu. 
2. Move the cursor into the map; your cursor should be a crosshairs with a circle.  As 

you move it near one of your GPS points, you should see it jump slightly, or "snap" to 
the point.  (By the way, from the Editor pulldown menu, you can select Options and 
click on the "General" tab to specify a snapping tolerance; this is the distance away 
from a point that you must be to avoid snapping to that point). 

3. Move your cursor onto one of your GPS point and click.  This starts the polygon at 
that point. 

4. Move your cursor to the next GPS point and click to digitize that point. 
5. Continue until you come to the last point (before you return to the starting point); at 

this one, you will double-click to end the polygon at this last point.  The polygon will 
automatically close back to the first point. 

6. Your polygon should be created.  If it did, from the Editor menu select "Stop Editing" 
and save your edits. 

28. You now have a polygon file; you can change the map symbology, set transparency, etc. 
 

Section 7. Computing Polygon Area in ArcMap. 
Now we have a polygon of the area you walked around with the GPS unit.  However, ArcMap has not 
automatically calculated polygon area.  We must force it to do that now! 

 
29. First, we need to add a field in the attribute table of your polygon shapefile to store the 

polygon area: 
1. Open the attribute table of the shapefile that you created in the previous section. 
2. Click the Options button on the table, and select "Add Field…" 
3. Set the field name to be "Area" 
4. Set the field type to be "Double" 
5. Set the precision to be 12 (this will be how many digits the field will hold). 
6. Set the scale to be 4 (this will be how many digits to the right of the decimal). 
7. Click OK. 

30. Next, we need to make ArcMap compute the polygon area and store it in this field: 
1. Right-click on the Area column heading in the attribute table. 
2. Select “Calculate Geometry”. 
3. Set the property to be calculated to "Area”. 
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4. Specify that you will use the coordinate system of the data source. 
5. Set the Units to be square meters; click OK. 
6. When you have followed these instructions, you should see a value for area in the 

attribute table. 

31. What is the polygon area according to ArcMap (in sq. m.)?    
 
Key Point: Now you have proved that you can calculate a polygon area just as well as a powerful 
GIS can.  Obviously, manual calculation of polygon area can get very tedious if you have lots of 
GPS points, which would be the case if you followed a winding road or stream as part of your 
area boundary.  But for simple shapes, you can do pretty well with a spreadsheet or calculator. 
 
Also, you have learned to digitize a polygon on-screen, snapping to features in other layers.  If 
you have roads or streams layers, you can "snap" to them to make sure your digitized line follows 
them exactly.  There are lots of additional tools to digitize (such as appending adjacent polygons 
without slivers or overlaps). 

 
 
Section 8. Generating a map of the Polygon in ArcMap 
 
Task: Using the geographical knowledge and skills, generate a map of the polygon you have created 
in ArcMap for dissemination.  
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FOR 4114  
GPS Data Collection Sheet 

 
 
PointID XCoord YCoord Elev Comment 

     

     

     

     
     

     

     

     

     

     

     

     

     

     

     

     

     

     

 
PointID:  Enter an identifier for your point, such as "Pt001"; you may wish to use the identifier 
that the GPS receiver automatically assigned the point. 
XCoord: X-Coordinate (Longitude) in UTM meters (Zone 17, NAD 83) 
YCoord: Y-Coordinate (Latitude) in UTM meters (Zone 17, NAD 83) 
Elev: Elevation in meters 
Comment: Optional text comment about your point location 
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7.0 Georeferencing 

7.1 Introduction  
Most often digital geographic data are acquired by scanning aerial photographs or paper maps. Once 
the data are input they need to be assigned their proper map coordinates so that they will occupy a real 
world space. 
 
Georeferencing defines the location of a dataset using known map coordinates and assigns it a 
coordinate system. This allows for the dataset to be viewed, queried, and analyzed with other 
geographic data.  Typically in a GIS environment such as ArcMap, raster datasets (such as images) 
are georeferenced using a control layer or control points. This layer contains known coordinates and is 
used as a point of reference for the georeferencing process. 

7.2 Procedures 
1. Click on FileàAdd Data and select the ‘CIM_wak_day_7 (32).TIF’ from your working 

folder. 
2. Note: The control layer is the layer with the known coordinates 
3. Click on FileàAdd Data and select the dataset to be georeferenced 
4. Turn on the Georeferencing toolbar by clicking on ViewàToolbarsàGeoreferencing 

 

 
 

5. Make sure that the Layer list box is set to the image that is to be georeferenced. 
6. From the toolbar click GeoreferencingàAuto Adjust.  This will update the image with the 

addition of each control point 
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7. Zoom to the full extent of the coordinates systems 
8. Most likely the image will not be visible by default.  This can be corrected 

by clicking GeoreferencingàFit To Display 
 

 
 
9. Note:  When georeferencing a map to a specific control layer it is good practice 

 to project the control layer using the same projection as the paper map in order to minimize any 
distortion 
 
 
 

7.3 Geoferencing the data 

1. Begin by clicking the Add Control Points button  
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2. Select a point on the image and add a control point.  When georeferencing images, it is often 
helpful to use the corner coordinates 

3. Tip: Use the magnification window to avoid having to zoom in and out at different extents.  
Click on WindowàMagnifier 

 
4. Continue adding the control points until the desired level of accuracy has been achieved. 

 
5. The image will update automatically if Auto Adjust is enabled 
6. At any time the attributes of each control point can be viewed by clicking on the View Link 

Table button .  This dialogue shows the map coordinates of the source (X Source and Y 
Source) and destination points (X Map and Y Map).   

7. By double clicking on the X Map and Y Map, the destination coordinates can be altered if 
they are incorrect. Also, any control point can be deleted via the Link Table dialogue 

 
8. Once four control points have been added an RMS error can be calculated for each point. The 

RMS error measures the accuracy of the control points and can be used to find inaccurate 
entries.  Frequently, major projects will require that the RMS error does not exceed half the 
pixel size, however, other projects will just try to minimize the amount of error.  Acceptable 
error levels depend on the accuracy required for the project and the data being georeferenced 



Pilot course content – Human Capacity Development Framework Uganda 
 
 

 
Page 59 of 76 

 
 

9. Once all the control points have been added the image must be updated and, if needed, 
rectified.   

10. From the toolbar click GeoreferencingàUpdate Georeferencing to store the control points.  
If this image is going to be used in ArcMap again there is no immediate need to rectify the 
image.  Once the image is added to ArcMap it will be transformed on the fly using the 
coordinates obtained from the control points.   

11. A permanent transformation can be applied by Rectifying the image 

 
 

12. To Rectify the image, click on GeoreferencingàRectify and specify the Output path and 
filename.  Leave all other values as default 

 
13. The image will be transformed and a new raster will be created in a TIFF file format 
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8.0 Digizitilisation  

8.1 Introduction   
Digitizing in GIS is the process of converting geographic data either from a hardcopy, digital or a 
scanned image into vector data by tracing the features. During the digitizing process, features from the 
traced map or image are captured as coordinates in point, line, or polygon forma 

8.1.1 Heads up digitizing 
Heads-Up digitizing is a technique that is useful for capturing or updating data from digital imagery 
on screen. High-resolution digital imagery now allows GIS users to edit and delineate features directly 
on the screen using desktop GIS software.  
 
The following considerations should be carefully planned out in advance.  

1) The user must document procedures when using this technique.  
2) Scale used for data capture should be established & documented. Recommended scales for 

digitizing should be between 1:1200 to 1:4000 over DOQQ. Below 1:1200 the imagery 
becomes extremely blurred. Above 1:4000 accuracy could be compromised.  

3) Digitizing tolerances should be established and documented.  
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4) Users should maintain clear definitions or classifications of features that are being interpreted 
and delineated.  

5) Ground truth (field verification) remains an important step in establishing the quality of 
heads-up digitizing, particularly for land cover delineation.  

6) Make sure appropriate entries concerning  

8.1.2 Tablet Digitizing  
Tablet digitizing is a common method of getting data into a GIS. The procedure involves tracing lines 
or locating points with a computer mouse on a digitizer. The manuscript’s lines should be clear and 
complete with no gaps or shortfalls. Operators should not interpret and digitize at the same time. The 
digitizer should concentrate solely on capturing the exact nature of the features.  
 
All maps shall be edge matched prior to digitization to eliminate cartographic errors and reduce digital 
problems. Digital accuracy shall be evaluated by proof plotting the digital data to the base at the same 
scale as the manuscript and overlaying the data to the original map. The line work should be digitized 
in such a way as to create a digital copy that is within +/- one line width of the original. Edits can be 
flagged and corrected such that the standard is met. Coverage TICS should be identified and RMS 
errors documented in the metadata. 
 

8.2 Short description ‘How to digitize’ 

8.2.1 Load the satellite image 

 
Main menu 

Click in the Main Menu on Add Data 

  

Click on Add Data 

 

Linked Folders 

Add 
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Click on the Folder, containing the data. 

 

 

 
Click on Add 

Click on the folder 
MUK 

Click on the image name 

The image is 
selected! 
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Display of the selected image 

 
Zoom in to enlarge the area of the Makerere University 
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8.2.2 Create a new shape file 

 
The Catalog window opens. 

                    
                                                                                                                               

 
The window Create New Shapefile will open. 
 

Click on Window Catalog 

Mark the folder in which 
you want to store your new 
file. 
Then right click on the 
mouse 

Click on New 

Click on Shapefile 
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Window Create New Shapefile 

Select the Feature  
Type:Polygon 

Click on Edit to add the 
Spatial Reference 
Properties 
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8.2.3 Select the Spatial Reference System 

 
 
The following sequence of windows will bring you to the used coordinate system: 
WGS84 UTM Zone 36N.prj 
 

      
 

    
 

Select a predefined 
coordinate system 
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New created vector is added to the Table Of Contents 

8.2.4 Start digitalization 
Start editing 

 
When you click on Start Editing the window Create Feature will open. 
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Double click at the end to finish digitalization. 

1) Mark the 
shapefile 

2. Select the 
digitizing tool 

First point 

Continue …. 

Last point- 
Double Click 
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Figure 1: Result 

8.2.5 Save and Stop Editing 

 
 
You can save your digitalization during Editing. 
After finishing you save and click on Stop Editing. The window Create Feature will be closed. 
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9.0 Terrain analysis for hydrological and hydraulic modelling 

9.1 Introduction  

 

9.1.1 What is a terrain? 
A multi-resolution layer providing access to elevation values for use in analysis with functions for 
slope, aspect, and hillshade. 

9.1.2 Description 
This dynamic image service provides numeric values representing ground surface heights, based on a 
digital terrain model (DTM). The ground heights are based on multiple sources. Heights are 
orthometric (sea level = 0), and water bodies that are above sea level have approximated nominal 
water heights. 

9.1.3 What can you do with this layer? 
1. Use for Visualization: This layer is generally not optimal for direct visualization. By default, 

32 bit floating point values are returned, resulting in higher bandwidth requirements. 
Therefore, usage should be limited to applications requiring elevation data values. 
Alternatively, client applications can select from numerous additional functions, applied on 
the server, that return rendered data. For visualizations such as multi-directional 
hillshade, hillshade, elevation tinted hillshade, and slope, consider using the appropriate 
server-side function defined on this service. 

2. Use for Analysis: Yes. This layer provides data as floating point elevation values suitable for 
use in analysis. 

 
This layer has server functions defined for the following elevation derivatives: 

1. Slope Degrees 
2. Slope Percentage 
3. Aspect 
4. Ellipsoidal height 
5. Hillshade 
6. Multi-Directional Hillshade 
7. Pre-symbolized Elevation Tinted Hillshade 
8. Pre-symbolized Slope Degrees 
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9. Pre-symbolized Aspect 

 

9.1.4 Data Sources 
The data for this layer comes from the multiple sources listed below, with original source data in its 
native coordinate system.  
 

 

9.1.5 Accuracy 
The accuracy of these services will vary as a function of location and data source.  
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9.2 Introduction to Shuttle Radar Topography Mission Elevation data 

9.2.1 Description  
The SRTM data (30m) shall be used for this exercise.  
 
The Digital Elevation Data (DEM) contains one elevation value (as measured above Mean Sea Level) 
in each pixel, or cell, of data. 

9.2.2 Release of data 
On September 23, 2014, the White House announced that the highest-resolution topographic data 
generated from NASA's Shuttle Radar Topography Mission (SRTM) in 2000 was to be released 
globally by late 2015. The announcement was made at the United Nations Heads of State Climate 
Summit in New York. Since then the schedule was accelerated, and all global SRTM data have been 
released. 
 

NASA has released a void-filled version of the Shuttle Radar Topography Mission digital 
elevation model, known as "SRTM Plus" or SRTM NASA Version 3. SRTM Plus uses SRTM 
Version 2 where the radar interferometric method was successful (not void). Most voids are 
filled with elevation data from the ASTER GDEM2 (Global Digital Elevation Model Version 2). 
ASTER is a sensor on NASA's Terra satellite that uses stereoscopic imaging to measure 
elevations via optical parallax where not obscured by clouds. Additional void filling of small 
areas used the GMTED2010 elevation model compiled by the US Geological Survey. SRTM 
Plus was produced under NASA's "Making Earth System Data Records for Use in Research 
Environments" (MEaSUREs) Program. 

 
The image at left has data samples spaced every 90 meters (295 feet); the image at right has samples 
spaced every 30 meters (98 feet). 
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9.3 Procedures 
1. Launch ArcMap software and load the following datasets 

a. Digital Elevation Model (from the ‘terrain analysis’ folder) 
b. Mbale District administrative boundary 

 

 
 

2. Extract the Mbale boundary from the broader elevation data for easier manipulation and 
rendering 
a. Load the arcTOOL box 
b. Spatial analyst tools  - Extraction – Extract by Mask 
c. Input raster – Ug_elevation; while  
d. Feature mask data – Mbale district and click OK 
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3. To extract elevation derivatives such as slope, hillshade follow the steps outline below 
a. Arctoobox – 3D analyst tools – Raster surface – aspect, contours, hillshade, slope 
b. Hillshade 
The hillshade tool creates a shaded relief layer from a surface raster by considering the 
illumination source angle and shadows. The resulting hillshade raster creates a pseudo 
3D display of topography 
 

 
 

c. For this exercise, I will create the hillshade and you will be required to proceed with 
the subsequent layers (slope, aspect, contours etc) 
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d. Accept defaults for Azimuth and Altitude  
 
e. Note: You can try checking on Model Shadows, it can be helpful in visualization, but 

in some cases it may make little difference.  
 
f. Z factor (optional): For DEMs with vertical (Z) units in meters, enter 1, or else leave 

as default 6. Click OK to run.  
 

g. The output raster is added to your map as a new layer 
 

Output = Hillshade for Mbale District 

 
 

4. Proceed with the creation of slope, aspect, contour datasets 
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9.4 Home work 
Undertake 3D Analysis/Visualization using ArcScene using the Mbale DEM 
Pseudo-3D visualization is achieved in GIS by rendering surfaces in a perspective view, animating 
these displays, and draping other geographic features or images. 
 

 
 

9.5 Watershed modelling using ArcSWAT and HECRAS 
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